Schleuder/ news/

schleuder on debian jessie

If you're running Schleuder on Debian and want to dist-upgrade, you'll run into the problem that the outdated dependencies of Schleuder v2 are not available (or even installable) on Debian Jessie. Here's a way we've been told about you still can get Schleuder to work on Debian Jessie:

  1. Before upgrading, make sure you have rubygems1.8 and ruby1.8-dev installed.
  2. Upgrade to Jessie but keep enabled security updates from Wheezy. (Yes, I know.)
  3. Run:

    # gem1.8 install ffi tmail magic
    # gem1.8 install log4r --version 1.6.13
    # gem1.8 install gpgme --version 2.0.2
    
  4. Edit /usr/bin/schleuder and add, right after the she-bang:

    require 'rubygems'
    $:.delete('/usr/lib/ruby/vendor_ruby')
    

We can't promise that this hack won't break anything but we've haven't heard about such downsides. Good luck!

(In case you find this situation awful please consider helping out to push the development of Schleuder v3.)

Update

To make schleuder-newlist work, you apparently have to additionally follow these steps:

  1. Install the 'highline'-gem in a specific version:

     # gem1.8 install highline --version 1.6.21
    
  2. Edit /usr/bin/schleuder-newlist and add, right after the she-bang:

     require 'rubygems'
     $:.delete('/usr/lib/ruby/vendor_ruby')